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Revised: 17 October 2019 

 
Data Topic  Level 

X-ray single crystal data structure with pseudo-
merohedric 3-fold 
twinning 

Advanced 

Tasks 
Solving a structure with pseudo-merohedric 3-fold twinning using Jana2006 software 

- Finding twinning matrix from group → subgroup transformation.  

- Transformation to four times smaller cell.  

Initial data 
Data 
Single crystal data measured with Oxford Diffraction four-circle diffractometer 
Input files:  
CsLiSO4.hkl, CsLiSO4_red.sum 
Additional information: 
Frame scaling, absorption correction: done by the diffractometer software  
Chemical formula: CsLiSO4 
 
 
  



Instructions  

I. Data import 

1. Creating new jobname 

Start Jana2006 
“File → Structure → New” opens a file manager (Step 1) 
Left pane: locate directory with input files; Right pane: double-click CsLiSO4 (Step 2) 

Step 1 Step 2 

  

2. Import wizard 

Select “Known diffractometer formats”; NEXT (Step 1) 
Select “Oxford Diffraction → CCD”; NEXT (Step 2) 
Select “Input from “sum” file”; OK (Step 3) 

Step 1 Step 2&3 

  

Warning; OK (Step 4) 
  



Leave all settings unchanged; NEXT (Step 5) 
Leave all settings unchanged (leave Twinning checkbox clear); NEXT; OK; (Step 6)  
The program reads 11132 reflections from hkl file 

Step 5 Step 6 

  

For absorption correction select “None or done before importing”; NEXT (Step 7) 
FINISH (Step 8)   

Step 7 Step 8 

  
 

 

3. Data Repository 

OK; YES to accept the data set (Step 1) 
Nest; (Step 2) 

 
 
 
 
 

 
 
 
 

 



Step 1 Step 2 

 

 
 

  

II. Symmetry and data merging  

1. Symmetry wizard 

[On the screen: “Tolerances for crystal system recognition”.] 
Leave all other settings default; NEXT (Step 1) 
[On the screen: Select Laue symmetry] (Step 2) 

 

Step 1 Step 2 

  

Notes  
We can see that hexagonal symmetry is slightly violated, because corresponding Rint is 
about 14%. On the other hand, an orthorhombic symmetry with setting “-a-b,a+b” has 
Rint comparable with the triclinic symmetry, given much higher redundancy of 
equivalent reflections.  



Press BACK 
Check „Introduce twin laws in case of subgroups“ (Step 3) 
 

This time, the three orthorhombic cases gives the same internal R factor. 
Select the highlighted orthorhombic Laue symmetry; NEXT (Step 4) 
 

Notes  
The three orthorhombic cases are related to the three twin domains. The selected one 
gave us in the previous test the lowest Rint. This means that this domain is more 
populated than the others. 

 
On the screen: [Select cell centering] (Step 5) 
Press “Show/modify X centering” to see the individual centering vectors 
 
 
 

 
For cell parameters being so close to hexagonal, a metric merohedric twinning is highly 
probable. However, here the three orthorhombic settings have quite different Rint. This 
indicates that the structure has symmetry lower than hexagonal and that the sample is 
either not affected by twinning or that twin domains are not equally populated.  
 
In the next step, we will repeat test of Laue symmetry but this time considering 
twinning. That means for any subgroup of 6/mmm the program will generate 
corresponding pseudo-merohedric twinning matrices and it will use only symmetry 
elements, which are present in a twinned structure for general case of not equally 
populated twin domains. 

Step 3 Step 4 

  



Notes  
We can see the centering vector (½ ½ 0) corresponding to the C centering but also 
additional vectors (½ 0 0) and (0 ½ 0) suggesting that a and b unit cell parameters 
could be halved. Although we cannot conclude unequivocally that the correct cell is 
really four times smaller than found from diffraction pattern, the natural way is to 
start with a smaller cell allowing indexing of all diffraction spots.    

 
 

Step 5 
 

Step 6 

  
 

 

Notes 
The space groups highlighted by red, green and blue color (Step 6) have the smallest 
ratio between the number of reflections violating space group extinctions (I>3σ(I)) and 
the number of all measured systematically reflections. The first space group in each 
block is the centrosymmetric space group and the others are its non-centrosymmetric 
subgroups. In all these cases, the FOM (Figure of Merit) is low and we cannot exclude 
none of them. In next steps, we will use the Superflip program and test the 
centrosymmetric space group from each block.           

 

Cancel; No for repeating the test; 
“File → Structure → Save as” and use a new name for example “CsLiSO4-basic” but do not 
continue with the new structure. 
“File → Reflection file → Make space group test” and continue to the step for selection of 
space group; (Step 7) 
Select the space group Pmmb; NEXT; 
Accept space group in the standard setting with twining matrices; FINISH (Step 8) 
 
 



       No for repeating the test; 

“File → Reflection file → Create refinement reflection file”; 
Next; (Step 9)  
OK; OK; (Step 10) 
Next; OK; 
Finish; 
 
                           Step 9                        Step 10 

  
 
Next; OK; Finish 

Start “Structure solution”;  
Define the formula Cs Li S O4  and run solution;  (Step 11) 

                                       

 

Step 7 Step 8 

  



                                         Step 11                                                                 Step12 

      
 
 

Notes 
The selected space group Pmma was not confirmed by the Superflip as shown in the 
smb agreement (Step 12). The space group derived by Superflip is Pbmm in the 
standard setting for Pmma.   

 
 

 
Close the window with Superflip output and press the “Quit” button; Yes to discard the 
solution; 
 [On the screen: basic window of Jana] 
 
“File → Structure → Copy in” and select  the structure “CsLiSO4-basic”; Rewrite all files; 
“File → Reflection file → Make space group test” and continue to the step for selection of 
space group;  
Select the space group Pmcb; NEXT; 
Repeat the same procedure as for Pmmb; 
 
Notes 
For this choice, Superflip does not converge. 

 
 
 
 
 
 
 
 
Repeat the whole procedure for Pmcn (in standard setting Pmna): 
 



 
                             Step 13                                                                    Step14  

           
 

Notes 
83 observed reflections will be discarded (see Step13) due to the selected space group. 
This is probably caused by spurious peaks, which are present in the diffraction pattern. 
 
The Superflip confirmed the space group Pnma.  
 
The transformation suggested at the final step of the space group test produces an 
orthorhombic unit cell with four time smaller volume compared with the previously 
tested orthorhombic unit cell. Such unit cell alone could not index all diffraction spots, 
but combined with a three-fold twinning it can. The indexing of the hexagonal 
diffraction pattern with a three-fold twin of this small orthorhombic unit cell is 
indicated in the next figure. 

 



 

 

2. Space group test results 

 [On the screen: basic window of Jana] 
Check new cell parameters and symmetry with EditM50 (Step1) 
Cell parameters 8.8048 5.4505 9.4301 90 90 90 
Space group Pnma 
ESC 
[On the screen: basic window of Jana] 
Start “Parameters → Twin fractions” (Step2) 
  



 

Step 1 Step 2 

 

 

 
Notes  
The initial volume fractions are equal but we already know they will be different; 
otherwise hexagonal Laue symmetry would be indicated with good Rint.   

Click inside the textbox “twvol2” and press “Show twinning matrix” (Step3) 
1 0 0 / 0 1/2 -1/2  / 0 3/2 1/2 
Click inside the textbox “twvol3” and press “Show twinning matrix” (Step4) 
1 0 0 / 0 -1/2 -1/2  / 0 3/2 -1/2 
These twinning matrices are related to the current orthorhombic unit cell 

Step 3 Step 4 

  

Return to the basic window  
Start “Edit/view → Editing of M90 file” (Step5) 
 
  



 

Step 5 M90 

  

 
Notes  
The numbers inside the orange rectangle are twin flags. All flags except several 
reflections at the end of the file have the twin flags equal to “1” because most 
reflections can be indexed in the first domain. The reflections at the end of the file with 
the twin flag “2” and “3” are the ones, which cannot be transformed to the first 
domain because after such transformation they would have indices which are not 
compatible with C centered cell. 

 

III. Structure solution  

“Run → Structure solution” 
[On the screen: window of Structure solution] 
In “Formula” textbox check list of chemical elements for CsLiSO4: Cs Li S O 
Select “Superflip”, “Peaks from Jana2006”; leave other settings default; “Run solution” 

Notes  
Superflip converges (after noise suppression) with R value 22%. The suggested space 
group by Superflip is Imma but for twins such prediction is unreliable. On the other 
hand, Superflip confirms the symmetry elements of the current space group symmetry 
Pnma. 

Press CLOSE to leave the listing 
Press “Draw structure” 
Press “Accept last solution” 
Start EditM50; (Step1) 



Go to page Composition; change Formula units to 4; press Formula from M40; (Step2) 
OK; Yes; OK 

Step 1 Step 2 

  

 

Notes  
In most cases, the formula will be Cs Lin S O4, where “n” can be zero, 1 or more. This 
means all heavy atoms except Li have been properly interpreted. If not, repeat the 
structure solution. 

Start “Edit atoms”; delete all Li atoms 
“Plot structure” 

 

Notes  
Diamond should show SO4 tetrahedron and Cs. For this plot, all bonds to Cs will need to 
be disabled through “Build – Connectivity” 

 



IV. Refinements and model improvement   

1. Refinement 

[On the screen: basic window of Jana] 
Right-click the icon of Refine. (Step1) 
[On the screen: refinement options] 
Define 100 of cycles, (Step2) 
Choose “YES+START”  
Refinement converges with R value about 9%, GOF about 9, 17 refined parameters 

Step 1 Step 2 

  

2. Twin volume fraction 

Start “parameters → Twin fractions” (Step1) 
Activate refinement of the twin fractions 
Activate refinement of the twin fraction (Step2) 

 

 
 
 
 
 
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 



Step 1  
Step 2 

 

 

Repeat refinement  
Refinement converges with R value about 5%, GOF about 5 
Twin volume fraction drops to 0.26 (twvol2) and 0.30 (twvol3). 
Start “Edit atoms” 
[On the screen: list of atoms] 
Press “Select all” and “Action → Edit/define” (Step3) 
Choose “harmonic” for ADP parameters.  (Step4) 
This defines anisotropic temperature parameters for all atoms. 
OK, OK, YES to save changes 

Step 3 Step 4 

  

Double-click the icon Refine. 
Refinement converges with R value about 4.4%, GOF about 4.4, 36 refined parameters. 



3. Find atoms missing using Fourier  
 

[On the screen: basic window of Jana] 
Right-click Fourier (Step1) 
Select “Map type” = “F(obs)-F(calc) – difference Fourier” (Step2) 

 

Step 1 Step 2 

  
OK; YES+START; YES to include new atoms  
[On the screen: Inserting/replacing of atoms] 
OK(Step3) 
[On the screen: List of peaks] (Step4) 

Step 3 Step 4 

 

 
 

Notes  
The strongest difference peak (Max1) has reasonable Li-O distances to oxygen atoms. 
We can add it as Lithium in the first highlighted symmetry position. 



 
Press “Include selected peak” 
For “Name of atom” type Li*; (Step5)  
TAB; OK; FINISH; YES to include the new atom.  

 
Step 5  

 

 

Run refinement 
Refinement converges with GOF ~ 3 and R(obs) ~ 2.7% for 39 parameters 

4. Extinction correction 

[On the screen: basic window of Jana2006] 
Open listing of Refine (by “Edit/View → View of Refine”) 
Press “Go to” and select “Statistics Fo, sin(th)/lambda after refinement” (Step1) 

Step 1 

 
 
 



Notes  
The Statistics show that the strongest low-angle reflections are systematically weaker. 
This is an indication that extinction correction is needed. 

 
Close the refinement listing 
“Parameters → Extinction” (Step2) 
Select “Isotropic-Becker&Coppens” “Type 1” “Gaussian”; OK  (Step3) 
Refinement of extinction coefficient is enabled by default 

Step 2 Step 3 

 

 

[On the screen: basic window of Jana2006] 
Run Refine 
Refinement converges with GOF ~ 2.7 and R(obs) ~ 2.2% for 40 parameters 
Start “Edit atoms”; change ADP of Lithium to harmonic 
Refinement converges with GOF ~ 2.6 and R(obs) ~ 2.2% for 43 parameters 
Right-click Refine; go to the page Basic 
Check “Instability factor from reflection statistics” (Step4) 

 
 
 
 
 
 
 
 
 
 
 

 



Step 4 

 

 

OK; YES+START 

 

Notes  

 
The final structure 
 
Refinement converges with R value around 2.3% and GOF 1.4, for 43 parameters 
In this case, the instability factor from reflection statistics seems to be reasonable 
because the structure of a three-fold twin is fully solved and data are not expected to 
contain more information. 
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