
Example 5.1: YPO 

Simple modulated structure with crenel 
Revised 16 October 2019 
 

Y(PO3)3 
 
Single crystal data measured with Oxford Diffraction four-circle diffractometer 
Input files: YPO.hkl, YPO_red.sum 
Frame scaling, absorption correction: done 

1. Creating new jobname 
Start Jana2006 
“File → Structure → New” opens a file manager 
Left pane: locate directory with input files 
Right pane: double-click YPO 

2. Import Wizard 
Select “Known diffractometer formats”; NEXT 
Select “Oxford Diffraction → CCD”; NEXT 
[On the screen: “Define basic input file:”] 
Select “Input from sum file”; file name “ypo_red.sum”; OK 
[On the screen: “Warning about appended data reduction runs”] 
OK 
[On the screen: “Complete/Correct experimental parameters”] 
Leave all settings unchanged; NEXT 
[On the screen: “Define the reference cell/split by twinning”] 
Leave all settings unchanged; NEXT 
For absorption correction select “None or done before importing”; NEXT 
FINISH 

3. Data Repository 
The line in data repository window corresponds to one data set. 
OK; YES to accept the data set 
[On the screen: “Information about starting symmetry wizard”] 
NEXT 

4. Symmetry Wizard 
[On the screen: “Tolerances for crystal system recognition”.] 
Symmetry wizard can be started separately by “File → Reflection file → Make space group 
test”. 
Leave all settings default; NEXT 
[On the screen: Select supercell] 
Select "Continue with the basic cell"; NEXT 
[On the screen: Select Laue symmetry] 
Select Monoclinic Laue symmetry; NEXT 
[On the screen: Select cell centering] 
Select I centered unit cell; NEXT 
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[On the screen: Select space group] 
Select C2/c; NEXT 
[On the screen: Select superspace group] 
C2/c(0b0)s0 
[On the screen: Final step of the superspace test] 
Accept the superspace group in the standard setting: C2/c(0b0)s0; FINISH 
 

5. Creating refinement reflection file 
We have finished creation of the file M95 (reflections converted from diffractometer format 
to Jana format) and M50 (cell parameters, symmetry). At this step we shall create the file 
M90 containing data set merged by symmetry, with extinct reflections omitted. 
NEXT to confirm threshold 3sigma 
[On the screen: settings for merging of reflections] 
Leave all settings default; NEXT 
Accept the data block and calculate coverage; FINISH 
[On the screen: Information that structure solution will start] 

6. Structure Solution Wizard 
[On the screen: window of Structure solution] 
In “Formula” textbox type list of chemical elements for Y(PO3)3: Y P O 
Select “use Superflip”; “Peaks from Jana2006” 
Select "Use a specific random seed" and type value 5555 
“Run solution” 
Superflip converges (after noise suppression) with R value 21%. It confirms the symmetry 
C2/c(0b0)s0. 
Generally, each starting random seed can give a different result, which in most cases allows 
correct solving the structure. However, the number of localized atoms and/or origin 
selection can be different. Fixing the random seed to 5555 guarantees that the Superflip 
returns the same result like described in this cookbook.  
For your own practice, we strongly recommend using the method, which repeats the 
Superflip run with several times. Then Superflip is choosing the best fitting result.                   
Close the listing and press “Accept last solution” to leave the structure solution wizard 

7. Verification of the structure solution 
Start “Edit/View → editing of M40 file”.  
It shows the structure parameter file. Experts knowing exactly the file format can edit 
individual parameters here. Much safer is to use corresponding utilities like “Edit atoms” 
allowing a user-friendly editing of structural parameters and modifications of the structural 
model.         
Start “Edit atoms”. It shows the same in a graphical interface; parameters of atoms can be 
accessed by double clicking on atom or by “Action → Edit/Define atoms”; 
OK 
Start EditM50, go to page Composition, change “Formula units” to 4 
Press “Formula from M40” 
[On the screen: Information about formula] 
The reason why the value of formula units was modified from 8 to 4 is that this number 
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leads to integer multiplicities for all atoms. This reduction also means that Y, P and some of 
O atoms are localized at special positions if the symmetry as proposed by the space group 
test. For the solution with previously used “randomseed 5555” the formula should be Y P3 
O8 (for Z=4). 
OK; YES for updating the formula 
Modify the formula to Y P3 O9; OK, YES to rewrite M50 file. 
This change was made to keep the ratio P to O 1:3 as expected. The correct structure 
formula and formula units can help in the process of completing the structure from 
difference Fourier maps. However, for structure factor calculation only type of atoms and 
their order in the formula are relevant.  
 
Run Contour; start “New plot”; select “Show de Wolff’s sections”; 
New map to draw “F(obs) – Fourier”; 
Press “Define atoms for de Wolff’s sections”; 
Select atom Y1 and section x2-x4: 
 

                                  
 
Press “Add”; OK 
Leave rest setting default; 
   

                               
 
OK; 
Then the modulation density will appear.  
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The plot illustrates that the electron density from Superflip contains reliable information 
about position modulation. The modulation curve results by interpretation of the electron 
density map by Jana. 
Quit Contour 
 

8. Origin shift to the position of Y1 
The atom Y1 should be localized at the inversion center in one of the following Wyckoff 
positions: 
4d (1/4,1/4,1/2); (3/4,1/4,0) + (1/2,1/2,0) 
4c (1/4,1/4,0); (3/4,1/4,1/2) + (1/2,1/2,0) 
4b (0,1/2,0); (0,1/2,1/2) + (1/2,1/2,0) 
4a (0,0,0); (0,0,1/2) + (1/2,1/2,0) 
In the next step we shall shift the origin to the position of the Y1 atom. This step is not 
necessary for the structure solution and refinement but it assures that the coordinates and 
plots will look as described in this cookbook 
Start “Tools → Transformations → Origin shift” 
[On the screen: Move the origin to:] 
Select Atom Y1 and press OK. 
Run “Edit atoms”; Select P and O atoms;  
Press “Action” and choose “Make symmetrically contiguous motifs; 
This will not only make an contiguous motif from PO, but also it will move motifs to the basic 
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cell.     
 

9. Verification of modulated functions found by Superflip 
Right-click the icon of Refine and select thumbnail “Various”. Use the button “Fixed 
commands”, select “Modulation parameters” and type * to the Atoms/parameters textbox. 
This fixes modulation parameters for all atoms. 
Press the button “Add”; OK; OK 
Start Refinement. 
The refinement should finish with R(obs) factors about 13%, 11%, 15% and 22% for all, main, 
1st order satellite and 2nd order satellite reflections. This means that we have reasonably 
good starting point to continue the solution. 
The screen output of Refine is closed after a delay. It is saved in refinement listing 
(“Edit/View → View of Refine → Go to → R-factors overview”) 

10. Refinement of the modulated structure 
Right-click the icon of Refine and select thumbnail “Various”. Use the button “Fixed 
commands” and disable or delete the previously used “Fixed command” 
Run refinement. 
You should get R values about 13%, 10%, 14% and 20% for 24 parameters. 
Start “Edit atoms” 
Press “Select all” and “Action → Edit/define” 
Choose “harmonic” for ADP parameters. 
OK; OK; Yes to rewrite changes 
Start Refinement. 
Refinement converges with R value about 11%, 8%, 12% and 20% for 94 parameters. 

11. Localization of the missing oxygen atom 
Right-click the icon of Fourier and select thumbnail “Basic” – select “Map type” 
“F(obs)-F(calc) – difference Fourier” 
In the thumbnail “Scope” select: “Automatically” and “Use default map orientation” 
OK 
Run Fourier 
The modulation curve of this additional atom is rather complicated and therefore we have 
to look at the density maps to see more details. First, we should check if the peak, 
representing possible position of the new oxygen atom, has been really localized in the 
difference Fourier map. 
[On the screen: Do you want to start the procedure for including of new atoms?] 
Answer yes. 
[On the screen: Inserting/replacing of atoms – setting of distance limits] 
Use default 3 Å; OK 
(The dialogue for adding maxima is also available through “Parameters → Atoms → New”) 
The dominating maximum (with the largest charge) should be close to the special position at 
(3/4,3/4,1/2) or to some of its equivalents, with reasonable distances to the atom P1 (about 
1.5 Å). 
Note the coordinates of the dominating maximum in equivalent position close to P1 
For the current structure model (random seed 5555) it should be 0.749, 0.725, 0.495 
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Round the coordinates to the closest special position and note them 
For the current structure model (random seed 5555) it should be: 0.75, 0.75, 0.5 
Leave the form without adding the new atom. 
Adding new atoms would add oxygen to a general position because its localized position is 
about 0.16 Å out of special position. 
Use Contour to see difference Fourier sections through the point (3/4, 3/4, 1/2). 
Start Contour, press “New plot”; Select “General contour procedure”  
Select “Calculate new ones” and “Draw maps as calculated”; OK 
In Basic thumbnail select “F(obs)-F(calc) – difference Fourier” and in the thumbnail “Scope” 
define the vicinity of the point (3/4, 3/4, 1/2): 
 

                                               
OK starts Fourier calculation 
The first section is immediately plotted: 
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The resulting map must be summed over x2, x3 direction to see the correct modulation curve 
Press “Sum ON”; select “x2” and “x3” leaving the intervals defaults; OK 
The resulting map shows the shape of modulation: 

 
 
Analogously (starting with button “New plot” followed by “Calculate new ones”), calculate 
and plot the section x2-x4 and the section x3-x4: 
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The modulation has a discontinuity at the point with x4=0. This is clearly visible from the 
map showing evolution of the x2 atomic coordinate (the x2-x4 section). 
 
Very weak effects like modulation of light atoms in a structure containing heavy atoms are 
usually not directly detectable from the regular Fourier map. However, they can be detected 
from the difference Fourier maps calculated for a structure where the relevant atom is 
omitted. For this reason, we will save this map for future use.  

Close “Contour” 
“File → Structure → Save as” and use a new name for example “YPO-for-maps” but do not 
continue with the new structure. 

12. Inserting the missing oxygen atom 
From the previous we know that the modulation function of the new atom at (3/4, 3/4, 1/2) 
has a discontinuity and therefore a crenel function will be used. In the x2-x4 difference 
section we found that the length (delta) of crenel is one and its center (x40) is located at 0. 
“Parameters → Atoms → New”, select “Coordinates from keyboard”; OK 
Type the coordinates 3/4 3/4 1/2, press “Use new coordinates” 
Select the symmetrical position making the shortest distance to P1 and press “Include 
selected peaks”. 
[On the screen: Complete information for the new atom] 
For “Name of atom” type “O*” followed by TAB 
This selects the chemical type oxygen and the label with the first available sequence 
number. 
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OK; Finish; YES to include new atom 
 
Now we have to define the crenel function 
 
Run “Edit atoms” and select the new atom (probably O5). 
“Action → Edit/define” check “crenel” and define “1” for “delta” and “0” for “x40”; OK 
This is width and centre of the crenel function 
  
 

                           
 
 
add one position modulation wave in the textbox “Position” 
 

 
 
Select "Legendre polynomials in crenel interval" 
OK; OK; Yes to rewrite 
 
Draw Contour section x2-x4 for (3/4 3/4 1/2) - like previously 
Press "Atoms edit" and add O5; OK 
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The Contour plot shows the initial modulation function for O5 

 

13. Refinement of the complete structure 
Right click on the Refine icon, switch to “Basic” 
Define there number of cycles 100 and damping factor 0.2. 
Damping factor multiplies the parameters changes 
Start refinement 
 

→ R about 9%, 6%, 10%, 20% for 98 refined parameters 
 

Draw Contour section (without Fourier calculation!) x4-x2 for (3/4 3/4 1/2) - like previously 
Press "Atoms edit" and add O5; OK 
The Contour plot shows the crenel modulation function for O5 combined with one 
modulation wave 
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Run “Edit atoms”, select all atoms, press “Action” and select “Edit/Define atoms” 
Modify all ADP parameters to harmonic ones by double-clicking the corresponding radio 
button 
Yellow indicates locked objects. Locking occurs when the corresponding parameters are not 
the same (or of the same type) for the selected atoms. In our case ADP is harmonic for most 
of atoms but isotropic for the newly added O5, this is the reason for locking of radio buttons. 
The text box for site occupancy is also locked because some atoms are in special positions. 
A locked object can be unlocked by double-click. 
Add another one positional modulation wave for all atoms using the textbox “Position”. 
Save changes and start refinement 
 

→ R about 5.6%, 3.4%, 6%, 18% for 141 refined parameers 
 

Run “Edit atoms”, select all atoms and (using the button “ADP 2nd”) define two ADP 
modulation waves for all atoms. 
Start refinement 
 

→ R about 3.4%, 2.5%, 3.5%, 9.0% for 297 refined parameters 
 

“File → Structure → Save as” make a backup copy with name e.g. ypo-final 

14. Check modulation curves with maps for O5 
In this part we will check whether the refined modulation function for oxygen O5 
corresponds to the electron density map found previously from the difference Fourier maps. 
We are making this check because refinement of sawtooth function for oxygen in the 
structure containing the heavy yttrium could be unreliable 



 
12 Jana2006 Cookbook, version October 2013 

 
 

 
Return to the result saved previously (YPO-for-maps): 
“File → Structure → Open”: select the name of the previously saved structure (“YPO-for-
maps”) 
Run Refine to re-generate phases 
(R factors 11%, 8%, 12% and 20%.) 
“File → Structure → Copy in” copy only (!!!) m40 from the final structure 
(From this point Refine must not be started) 
Run “Contour”; Choose “Show de Wollf’s sections” and difference Fourier; 
Define primary and secondary scope, 3 and 2 respectively; 
Activate summation of the maps over secondary directions:  
 

                          
 
Press the button “Define atoms for de Wolff’s section: 
Select atom O5 and activate calculations for all three sections x1-x4, x2-x4 and x3-x4: 
 

                      
The following maps will be obtained: 
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By this procedure we plot the final refined modulation curve of O5 together with the 
previously calculated Fourier map. The technical trick consists in the fact that Fourier 
calculation does not use M40; it uses M80 created by Refine. Only the modulation curve 
displayed by Contour is based on parameters from M40. 
 

15. Drawing of refined modulated structure 
Return back to the refinement result using “File → Structure → History” 
 
Drawing programs such as Diamond cannot draw a modulated structure directly. Jana2006 
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creates an approximant based on the refined modulated functions. During this process, the 
superspace symmetry is used to generate all atomic positions and the symmetry is reduced 
to P1. The size of approximant and the starting t value are to chosen to visualize different 
portions of the non-periodic matter. In our case the most convenient supercell is 1x8x1 as 
follows from the modulation vector being close to (0,3/8,0). 
 
“Plot structure” 
In Diamond symmetry operations must not be used for the approximant (no automatic 
structure, no supercell, no coordinations …. ). This is because Diamond does not know 
modulation displacements of newly created positions.  

16. Checking of refinement listing 
Start “Edit/View → View of Refine” 
Press “GoTo → List of serious warnings” 
The listing contains information that modulation of ADP leads to non-positive values for 
some values of t coordinate: 
 

 
Start “Grapht” 
Press New/Edit 
For “Parameter to draw” select “ADP parameter” 
For “Central atom” use “O1” (the label may differ) 
For “Principal” select “U(min)”; OK 
 
The following plot shows that U(min) is negative for a small region of t 

 
 
Create the same graphs for O4 and O5 
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Decreasing of number of ADP modulation waves often solves such situation: 
In Atoms/Edit select all oxygen atoms and decrease number of ADP modulation waves to 1 
Check refinement listing and Grapht graphs 
In our case it only helps for O4. The reason for bad ADP modulation of some oxygen atoms is 
probably caused by the fact the sample is more complicated than presented here. High 
exposition reveals another set of weak satellites, which need another q-vector for their 
indexing. The five-dimensional structure remains unsolved. 


