
Example 12.7: DyMn6Ge6 

Incommensurate magnetic structure – k=(0,0,0.1651); k=(0,0,0) 
Revised: 18 October 2019 
 

DyMn6Ge6 
 

Neutron powder data measured at 11K on DMC at PSI (Switzerland) 
Available at the Bilbao crystallographic server, database magndata, #1.1.10 
 
References:  
J. Rodríguez-Carvajal & F. Bourée,  EPJ Web of Conferences 22, 00010 (2012) 
 P. Schobinger-Papamantellos et al, Journal of Alloys and Compounds, 203 (1994) 243 
 
Input files:  dymn6ge6.dat (powder profile data) 

dymn6ge6_nuclear.cif (nuclear structure) 

1. Creating new jobname 
Start Jana2006 
“File → Structure → New” opens a file manager 
Left pane: locate directory with input files 
Right pane: double-click dymn6ge6 

2. Import Wizard 
Select “Magnetic parent structure: nuclear model from CIF”; NEXT 
Right pane: select the input file dymn6ge6_nuclear.cif; OK 

3. Define magnetic propagation vector and form factors 
[On the screen: Define magnetic propagation vector and form factors] 
Choose the “Number of non-zero magnetic propagation vectors” to ‘1’ and fill its value: 0 0 
0.1651 
Select atom type Dy; check “Use as a magnetic atom”; select “Magnetic formfactor <j0>” 
Dy3+;  
Select atom type Mn; check “Use as a magnetic atom”; select “Magnetic formfactor <j0>” 
Mn3+;  
NEXT; FINISH 
The parent structure is created 

4. Import the reflection file 
[On the screen: Specify type of the file to be imported] 
Select “Various CW format”; NEXT; 
Check that the name of the input file is “dymn6Ge6.dat” and the format is “PSI format”;  
Select “Debye-Scherrer method” 
NEXT 
[On the screen: Complete/correct experimental parameters]; 
Fill used wavelength 1.7037; Temperature 11; NEXT; FINISH 
[On the screen: Data repository] 
OK; YES to “Do you want to accept made changes?” 
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5. Refining of profile parameters by the le Bail technique. 
[On the screen: Information] 
NEXT 
[On the screen: Refinement of the powder profile by the le Bail algorithm] 
“Show powder profile” 
The background is relatively smooth and it can be described without introducing manual 
background. 
“Quit”; 
“Edit profile parameters”; 
 [On the screen: Powder options] 
In page “Cell” activate refinement of a and c parameters and the third component of the 
modulation vector – q3; 
In the page “Profile” keep the starting value of GW to 50 and activate its refinement; 
In the page “Corrections” activate refinement of “shift” parameter and change the number 
of used Legendre polynomials to 10 
OK; YES to save the changes 
“Edit refinement commands”; In the page “Basic” change the number of cycles to 20; OK 
“Run Refine”; 
The refinement should converge to Rp~4.95%. 
“Edit profile parameters”; 
[On the screen: Powder options] 
In the page “Profile” activate refinement of GU and GV 
Change the peak-shape function to pseudo-Voigt and activate refinement LX 
OK; YES to save the changes 
“Run Refine” 
The refinement should converge to Rp~2.98%. 
“Show powder profile” 
Select the region 2θ from 30 to 45 degs – use the button “X exactly”. A couple of observed 
peaks may correspond to some impurity. Also at about 2θ= 5, an anomaly in the background 
is observed. No peaks are possible there. 
“Quit”; 
“Edit profile parameters”; 
 [On the screen: Powder options] 
In page “Corrections”, press button “Define excluded regions” : from 0 to 7; “Add”, 
“OK”,“OK”; 
 “Run Refine”; 
The refinement should end with Rp~2.90%. 
NEXT; YES to leave the form for le Bail refinement 

6. Refinement of the scale parameter for the nuclear structure 
[On the screen: Refinement of the nuclear structure by the Rietveld method] 
“Edit refinement commands”; On the page “Various” select “Fixed commands”; 
In the case that the fixed command of form is “fixed all *” is already in the panel, do 
nothing. If not:  
Fix all parameters for all atoms (“*” for “Atoms/Parameters” textbox); “Add”; OK; OK 
“Run Refine” 
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The refinement should converge to Rp=11.6%, R(obs)=7.5% 
NEXT; YES to leave the for for Rietveld refinement 

 

7. Testing different irreps to get the best single irrep model 
[On the screen: Information]  
NEXT 
[On the screen: Representation analysis] 
 

   
 
This window has an information character. You can see here all irreps leading to magnetic 
ordering. The “details” buttons provide more information about an individual irrep and its 
connection to the kernel magnetic symmetry. 
NEXT 
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[On screen: List of kernels and epikernels] 
 

 
Select one of the hexagonal magnetic superspace groups based on average space group 
P6/mmm; NEXT; 
This will pass all present hexagonal magnetic superspace groups of type P6/mmm to further 
testing. We assume that both magnetic atoms should have non-zero magnetic moment. 
[On the screen: Select magnetic space group] 
 

 
 
Only the second magnetic superspace group allows for non-zero magnetic moments for Mn 
and Dy atoms.   
 
Select the second magnetic superspace group: P6/mmm.1’(00g)00sss and press “Start 
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profile simulation”;  
Press "X exactly" and focus the region 8-16 degrees; Press “Fit Y”:  
 

 
 

Two dominant magnetic peaks in this region have zero intensity. This means that the tested 
model does not describe the magnetic ordering correctly. However, in making such 
conclusion we have to take into account that the simulation procedure uses randomly 
generated magnetic moments and that the result can be affected by an actual random 
choice. This is why we recommend repeating the simulation when some doubt exists. 
“Quit”; “Back” and return to the “List of kernels and epikernels” and select one of 
hexagonal superspace groups based on P622.  
While the first one P622.1’(00g)t00s restricts the magnetic moments of the Dy atom to zero, 
the second one P622.1’(00g)-h00s allows non-zero magnetic moments for both magnetic 
atoms. The simulation profiles demonstrate that the intensity of both magnetic peaks in the 
interval (8-16) degs are generally non-zero:  
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8. Refinement of the magnetic structure in – P622.1'(00g)-h00s 
[On the screen: Select magnetic superspace group] 
Select the magnetic superspace group P622.1'(00g)-h00s 
Press ‘Continue with the selected magnetic superspace group’ 
[On the screen: Select structure name] 
Use the default name i.e. dymn6ge6_01 or any other; OK  
[On the screen: Basic window of Jana2006] 
Right-click the icon of Refine and select the page “Various” 
Use the button “Restrictions” and ensure that all atoms (i.e. *) are restricted to have 
identical ADP parameters. 
The restriction “restric * 13” has been set automatically when the program created the 
testing structure. To see the meaning of the restriction focus it by mouse and press “Load”.  
“Load” opens the restriction for editing. Make sure that "Coordinates" and "Modulations" 
boxes are cleared and press “Rewrite” to close the editing mode.  
OK 
Select the page “Fixed commands” and (similarly like in the previous step) ensure that all 
atomic positions are fixed in their current values (“fixed xyz *”).  
OK 
Select the page “Basic” and check if the “Number of cycles” is set to 100 and the “Damping 
factor” to 0.1; OK; Yes+start;  
Refinement converges with Rp~5.0%, R(obs)~ 5.0%, 4.6%, 5.7% for all, nuclear and magnetic 
reflections, respectively. 
Use “Profile viewer” and check the fit of the calculated powder profile 
Observe that some main reflections like (1 0 1 0) around 25 degrees or (2 -1 1 0) at about 40 
degrees are poorly fit. In order to exclude some additional nuclear effects we can allow the 
refinement of atomic positions: 
Right-click the icon of Refine and select the page “Various”. Use the button “fixed 
commands” and disable the command “fixed xyz”. Run refine again. 
Now the atom coordinates will also be refined. The refinement should end with Rp~5.0% and 
Bragg R factors R(obs)=4.9%, 4.5% and 5.7% for all, main and satellite reflections, 
respectively. (“View of Refine”). The improvement is minimal. Some of the main reflections 
remain poorly fit systematically with too low intensity. This fact can lead to the conclusion 
that an additional magnetic ordering with k=0 is present. 

9. Refinement in the subgroups allowing magnetic wave (0,0,0) 
[On the screen: Basic Jana window] 
We try then the possibility that magnetic scattering occurs also at main reflections, i.e. an 
additional magnetic ordering with k=(0 0 0) is taking place. In the language of the symmetry 
group of the phase this implies to lower it, dropping the operation {1’|0001/2} associated 
with the existence of a single primary incommensurate wave vector.  
 
There are several maximal subgroups without this operation. Then can be generated by the 
Jana tool “Tools→Transformations→Go to subgroup structure”. As generators for the 
working group until now can be used: 

      {6+|0 0 0 5/6}:   x1-x2, x1, x3, x4+5/6 
{2_xy| 0 0 0 0}:  x2, x1, -x3, -x4 
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{1’|0001/2} :   x1, x2, x3 , x4+1/2 
The possible maximal subgroups will then be generated by: 
 
P622(00g)-h00 
{6+|0 0 0 5/6}:   x1-x2, x1, x3, x4+5/6, m 
{2_xy| 0 0 0 0}:  x2, x1, -x3, -x4, m 
 
P6’22’(00g)t00 
{6+’|0 0 0 1/3}:   x1-x2, x1, x3, x4+1/3, -m 
{2_xy| 0 0 0 0}:  x2, x1, -x3, -x4, m 
 
P62’2’(00g)-h00  
{6+|0 0 0 5/6}:   x1-x2, x1, x3, x4+5/6, m 
{2’_xy| 0 0 0 1/2}:  x2, x1, -x3, -x4+1/2, -m 
 
P6’2’2(00g)t00 
{6+’|0 0 0 1/3}:   x1-x2, x1, x3, x4+1/3, -m 
{2’_xy| 0 0 0 1/2}:  x2, x1, -x3, -x4+1/2, -m 
 
Make sure that your actual structure is the final refined structure from the previous step. 
 
“Tools → Transformation → Go to subgroup structure”; 
Press the “Refresh” button and select the generators: 
 
x1-x2  x1  x3 x4+5/6 m 
x2 x1 -x3 -x4 m 
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Press the button “Complete subgroup”;   
 

 
   
NEXT; NEXT 
[On the screen: Select one representative of the 2nd coset] 
Select the first operation. 
Generally, all selections would give the same result.   
NEXT; 
[On the screen: Specify the output structure] 
Select “dymn6ge6_01_subgroup_1” or any other 
NEXT;FINISH;”Yes” to the question “Do you want to continue with the new structure?” 
[On the screen: Basic window] 
Run “Edit Atoms”; Select atoms Dy1 and Mn1; Press the button “Action” 
Select “Reset modulation/magnetic parameters” 
Deselect “Magnetic parameters k<>0” 
Choose “Reset parameters randomly in the interval (-pmax,pmax) 
OK;OK;”Yes” to the question “Do you want to rewrite changed files?” 
Run “Refine”; 
Repeat the procedure for all subgroups listed above 
Use the “File→ Structure → History” to return to the final refined structure in 
P622.1'(00g)-h00s.  
 
P622(00g)-h00 
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Rp=4.8%, R(obs)=4.6%,4.2%,5.4% for all, nuclear and magnetic reflections, respectively.   
 
P6’22’(00g)t00 
Rp=4.8%, R(obs)=4.5%,4.0%,5.5% for all, nuclear and magnetic reflections, respectively. 
 
P62’2’(00g)-h00  
Rp=4.2%, R(obs)=2.9%,2.3%,4.0% for all, nuclear and magnetic reflections, respectively. 
 
P6’2’2(00g)t00 
Rp=4.8%, R(obs)=4.8%,4.3%,5.5% for all, nuclear and magnetic reflections, respectively. 
  
 
One of the symmetries clearly fits the data better. Observe that the strong misfit of some of 
the main reflections has disappeared. 
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The final common Uiso is negative but its absolute value is very small. 
Right-click the icon of Refine and select the page “Various” 
Use the button “Fixed commands” 
Select “Set individual’; File the edit box by the text “Uiso[*]”; Define value “Set to” zero 
Add; OK; OK; Press Button “Yes+start” 
Rp=4.1 %, R(obs)=3.4%,3.2%,3.8% for all, nuclear and magnetic reflections, respectively. 
Run “EditM50”; Go to the page “Magnetic parameters”; Change the magnetic form factor 
for Dy to <j0>+c<j2>  and Dy3+ 
OK; ”Yes” to the question “Do you want to rewrite M50 file?” 
Run “Refine” 
Rp=4.2%, R(obs)=2.9%,2.6%,3.6% for all, nuclear and magnetic reflections, respectively. 

 

10. Visualize the refined model with VESTA 
[On the screen: Basic window] 
Double click on the icon “Plot structure” 
Select “Draw approximant structure”; x from 0 to 1; y form 0 to 1; z from 0 to 6 (c* 
component of the propagation vector is close to 1/6)   
Select “Use Vesta to draw the magnetic structure” 
Press "Draw+return" or "Draw+continue" 
Select “Edit→Vectors” and modify “Scale factor for modulus” to 0.3 
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OK 
Press button “Properties…”; Go the page “Atoms” and modify “Radius” for all atoms 
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11. Transformation to the standard setting as used in MAGNDATA 
 [On the screen: Basic window] 
 
The structure has been already included into the database “MAGNDATA” in Bilbao 
Crystallographic Server and you can get originally publish results as follows:     
 
“Tools → Connect through internet to → Bilbao Crystallographic Server” 
Select “MAGNDATA”; Enter the label of the structure “1.1.10” 

In order to make work easier and faster you can skip this point and use the following table 
directly:    
 

  
The result as derived step by step from the representation theory is expressed in a different 
chiral domain than used in MAGNDATA. Therefore, we should transfer it to the equivalent 
chiral domain. 
[On the screen: Basic window] 
“Tools → Transformation → Change enantiomorph” 
Create a new structure with name e.g. “dymn6ge6_01_subgroup_3_chiral” 
OK; Yes to continue with the new structure 
Run EdiM50; Go the page “Symmetry” 
Now the superspace group is the same as used in MAGNDATA however there is a non-zero 
origin shift in x4 equal 1/6. 
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ESC 
“Tools → Transformation → Origin shift” 
Use shift to the point 0 0 0 -1/6 
OK 
The last point that has to be checked for a full comparison is if we are using in the same 
symmetry positions for the magnetic atoms Dy1 and Mn1. The positions of these atoms 
from 1.1.10 are: 
Dy1 (0,0,0) and Mn1 (0.5,0,0.251). 
[On the screen: Basic window] 
Run “Edit atoms”; Double click on Dy1 atom; Go to the page “Edit” 
The coordinates are (1,1,1) and this means that we can just rewrite them to (0,0,0) as such 
transformation does not change the modulation functions. 
In the case that the Mz0 is negative change it to positive.  
Move to the atom Mn1 
Its coordinates are (0.5,1,0.749). From the list of symmetry operations we can find that the 
symmetry operation: x1-x2,-x2,-x3,-x4+1/2 combined with the lattice translation (1,1,1,0) 
makes what is needed. 
OK; 
[On the screen: Select atoms to be used] 
Select the atom Mn1; Press button “Action”; Select “Transform selected atoms”   
Use the button “Fill by a symmetry operation”; Select x1-x2 -x2 -x3 -x4+1/2 –m; Modify the 
translation vector to 1 1 1 1/2 
OK; OK; Yes to rewrite files 
[On the screen: Basic window] 
Run “Refine” to check that all transformation did not change the solution 
[On the screen: Basic window] 
“Edit/View → View of Refine”; Press “Go to” and select “Changes overview” 
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 M0x M0y M0z |M| 

Dy1 
MAGNDATA 0.0 0.0 3.93 3.93 

Jana 0.0 0.0 3.86(12) 3.86(12) 

Mn1 
MAGNDATA 0.0 0.0 -1.15 1.15 

Jana 0.0 0.0 -0.87(9) 0.87(9) 
 

 

 
cos sin 

Mx My Mz Mx My Mz 

Dy1 
MAGNDATA 6.20 0.0 0.0 3.58 7.15 0.0 

Jana 6.11 0.0 0.0 3.53(5) 7.05 0.0 

Mn1 
MAGNDATA -1.88 -0.21 0.0 -0.85 -2.05 0.0 

Jana -1.50(12) -0.41(10) 0.0 -1.18(11) -2.38(10) 0.0 

12. Use of the option of polar coordinates for the moments to constraint further the Mn spin 
to have a circular modulation. 
[On the screen: Basic window] 
“File → Structure → Save as”; Use e.g. “dymn6ge6_01_subgroup_3_final” 
OK; No to the question “Do you want to continue with the new structure?”  
[On the screen: Basic window] 
Run “Edit atoms” 
[On the screen: Select atoms to be used] 
Double click on the atom Dy1; Activate option “in spherical coordinates”; 
Go the “Edit” page;  
For the magnetic moment k=0 only Mr0-amplitude is a free parameter. Both angles Mp0-φ 
angle and Mt0-θ angle are fixed by symmetry. 
Uncheck the refine flags for angular components if active. 
Press the button “Magnetic” to magnetic modulation waves. 
The only free parameter is the amplitude Mrsin1. The φ angle is fixed for cos wave to 90 and 
for sin wave to 0. This means that the circular modulation is fully induced by the symmetry.   
Uncheck the refine flags for angular components if active. 
Go to the atom Mn1 and activate option “in spherical coordinates”; 
Go the “Edit” page;  
For the magnetic moment k=0 only Mr0-amplitude is a free parameter. Both angles Mp0-φ 
angle and Mt0-θ angle are fixed by symmetry. 
Uncheck the refine flags for angular components if active. 
Press the button “Magnetic” to magnetic modulation waves. 
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For Mn1, the modulation parameters except the θ angle are symmetry free. In order to force 
a circular modulation, the constraints must be used: Mrcos1=Mrsin1, Mpcos1=Mpsin1-90. 
These equations are only roughly satisfied by the previous refined model, as shown after the 
transformation. 
 
Right click on the “Refine” icon; Select the page Various; Click on the button “Equations”; 
 
Define the equations mentioned above: 
  
Mp0[Dy1]=0 
Mt0[Dy1]=0 
Mrcos1[Dy1]=Mrsin1[Dy1] 
Mpsin1[Dy1]=90 
Mpcos1[Dy1]=0 
Mtsin1[Dy1]=90 
Mtcos1[Dy1]=90 
Mp0[Mn1]=0 
Mt0[Mn1]=180 
Mrcos1[Mn1]=Mrsin1[Mn1] 
Mpcos1[Mn1]= Mpsin1[Mn1]-90 
Mtsin1[Mn1]=90 
Mtcos1[Mn1]=90 
You can do either one by one or you can use pre-prepared file “Equations-circular.txt”. For 
the former method: 
Press the button “Edit” and use the copy-paste method from the file 
“Equations-circular.txt”.    
 
OK;OK; Yes+start 
Rp=3.83%, R(obs)=2.93%,2.43%,3.82% for all, nuclear and magnetic reflections, respectively. 
Which means that it is not significantly worse than the full refinement – see point 9. 
 

 M0x M0y M0z |M| 

Dy1 
MAGNDATA 0.0 0.0 3.93 3.93 

Jana 0.0 0.0 3.96(11) 3.96(11) 

Mn1 
MAGNDATA 0.0 0.0 -1.15 1.15 

Jana 0.0 0.0 -1.00(8) 1.00(8) 
 
After transforming from polar to crystallographic coordinates 
 

 
cos sin 

Mx My Mz Mx My Mz 

Dy1 
MAGNDATA 6.20 0.0 0.0 3.58 7.15 0.0 

Jana 6.18 0.0 0.0 3.57(5) 7.13 0.0 

Mn1 
MAGNDATA -1.88 -0.21 0.0 -0.85 -2.05 0.0 

Jana -1.88(10) -0.20(9) 0.0 -0.86(9) -2.06(8) 0.0 
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General note: Two different strategies for handling refinement keys in Jana2006 
From Petříček, V., Dušek, M. & Palatinus, L. (2014) Z.Kristallogr. 229, 345-352. 
 
“All refinable parameters are divided into two groups: automatic and user-controlled ones. The 
automatic parameters are those which can be usually refined without numerical problems: scale 
factors and extinction parameters; parameters describing position, ADP and their modulation 
for individual atoms as well as for molecules; background parameters of the powder profile; 
magnetic parameters. The user-controlled parameters are twin/phase volume fractions, atomic 
or molecular site occupancies, parameters of crenel modulation functions, parameters of 
multipole refinement and powder profile parameters for individual Bragg reflections. 
The automatic parameters are activated by default at the beginning of the refinement process 
while the user-controlled ones must be always explicitly activated by the user. The program 
always fixes the parameters which cannot be refined due to symmetry restrictions. In order to 
fix other automatic parameters the user is provided with a range of special fixing commands. 
This way is very useful for most cases because it minimizes mistakes in setting refinement flags. 
However, the program also allows switching to a completely manual mode, where all 
parameters are to be activated explicitly by the user, analogically to other refinement programs 
such as FullProf [29].” 
 
Handling of symmetry restrictions of magnetic moments in polar coordinates would be easier 
for most of users if the non-automatic procedure is used: 
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