
Example: K2V3O8 

Solution of (3+1)-dimensional incommensurately modulated structure with twinning from 
single crystal TOF Laue neutron diffraction data. 

The average structure of K2V3O8 is similar to that of fresnoite (JANA2006_Cookbook example 
5.4) 

Single crystal data were measured on the TOPAZ beamline at ORNL Spallation Neutron Source. 

Input files: K2V3O8_Niggli.hkl, K2V3O8_Niggli.mat 
Data reduction and Absorption correction: done with software of the diffractometer 

1. Creating new jobname
Start Jana2006
“File → Structure → New” opens a file manager Left pane: locate directory with input files
Right pane: double-click K2V3O8_Niggli

2. Import Wizard
Select “Known diffractometer formats”; NEXT
Select “TOPAZ”; NEXT
[complete/correct experimental parameters]
Change the temperature to 90; NEXT Leave all settings unchanged; NEXT
The program reads 26335 reflections;
OK; FINISH
OK; YES to accept the data set
CANCEL to cancel creating refinement reflection file

3. Symmetry Wizard

http://jana.fzu.cz/workshops/Jana2006%20Cookbook.pdf


Double click EditM50 and select symmetry tab;

The lowest symmetry is use by default. The space group test for single TOF data is skipped in 
the symmetry wizard as each reflection can be considerably affected by extinction, which is 
dependent on the actual wave length. Then testing of Laue diffraction symmetry can fail. 
However, for space group tests based on systematic extinction can still be performed; 

OK; Do not rewrite m50; Do not create reflection file; 
“File → Reflection file → Make space group test”; 

Change “Maximal deviation for cell length in [A]” to 0.03; NEXT 
OK; select tetragonal 4/mmm; NEXT  
Default select P centering; NEXT 
Select P4bm; NEXT 



(Several space group symmetries are possible based on the extinction condition and Rint, 
need other information or several attempts to determine the correct space group symmetry. 
User can follow example 5.4 to determine the correct space group symmetry for average 
structure) 
FINISH; OK and YES to accept changes 
 

4. Creating refinement reflection file 
YES to start the reflection wizard 
Follow default steps of the reflection wizard  
91/175 reflections discarded due to space group symmetry (some of these reflections are 
quite strong, indicates the true symmetry might be lower, which will be dealt with later)  
 

5. Solution of average structure  
Start “Tools → Transformation → Go to average 3d structure” For name use “ave_P4bm” 
Follow the steps of the Reflection wizard 
Continue with the new structure  
Start “Run → Solution” 
For Formula type “K V O” 
Rub “Start solution” – rirth mouse double click on the icon; 
Select “Superflip” and “Peaks from Jana2006” 
Select “Use a specific random seed” and type “111” for random seed 
With this option result of charge flipping will be the same in most computers and origin 
position and special atomic position will be equivalent with this cookbook. For normal work 
random seed should not be fixed. 
OK 
Superflip converges with R around 23% and confirms the selected space group 
Draw structure shows that all the peaks are assigned with oxygen atoms 



 
 

 
 
 
 
 
 



The four atoms in one layer originated from equivalent positions of O5 atom should be the K 
atoms, and the V atoms are missing 
Accept the result 
Run “Edit atom” and change O5 to atom the type to K: OK 
Select all atoms; Action; Rename selected atoms to “atom_type” + number 
Use harmonic ADPs for all five atoms 
Draw structure shows the correct position of K atoms 

 
 
Run Refinements on F(obs)**2 with number of cycles changed to at least 100, skip any 
warnings that might appear 
Refinement converges with Robs=7.03% 
Run difference Fourier with 0.01x0.01x0.005 resolution 
We need to find the position of the V atoms using the difference Fourier map 
Run Contour;  
New plot; Options - Fourier map, calculate new ones; draw maps as calculated 
 



                                      
 
 

 
 
 

“Run 3d maps” to plot the difference map in 3D, set the isosurfaces level to 1.5 to show 
only strong peaks. 
 
 
The large blue spheres are the negative peaks showing the position of V atoms. 



 
Right click Fourier function and open peaks tab, change charge integration sphere radius to 
0.3. (the neutron scatter off the nuclei of the atom, so the sphere radius is much smaller 
than the electron peak in X-ray diffraction) 

                                              
Run Fourier and add difference minima Min1 and Min2 as V atoms. 
The scattering length of V is negative, so the minimum peaks are what we should look for 
Right click refinement function; 
Go to the page “Various” and press button “Fixed command”; 
Select “Origin” and fill the atom O2 used for fixing the origin in the polar space group P4bm; 
Go to the page “Basic” and modify the dumping factor to 0.2 and enlarge the number of 
refinement cycles to 100;   



      Run Refinement 
Refinement converges with Robs=5.74% 
In EditM50 check formula: K2 V3 O8 with Z=2 
Plot structure to see the final average structure. 2D V tetrahedra and pyramid net work 
separated by layers of K atoms. 

 



6. Back to the modulated structure
“File → Structure → Open”: open “K2V3O8_Niggli”
In EditM50 enter formula “K V O” in composition
“File → Structure → Copy in”: import only M40 from the average structure "ave_P4bm"
Fix the origin in analogical way as for the average structure.
Run refinement on F(obs)**2.
Refinement confirms R value for the average structure:

7. Superspace symmetry



The translation part of the superspace symmetry operators needs to be completed. 
Start EditM50  
Go to page “Symmetry” 
Focus the textbox “Space group” and press TAB.  
The program offers the first symmetry operator needing to complete: 

 and 
At the first attempt try combination 0 0 for the first operator and ½ 0 for the second one.  
The program will not allow it.  
Unlike the case of Example 5.4, the number of discarded peaks due to the symmetry are 
about the same for the two different combinations 0 0 + 0 0 or 0 0 + ½ ½, due to the absence 
of second order satellite peaks or cross terms, which makes it not useful for determining the 
correct superspace group. Therefore, both cases need to be tried in the refinement and see 
which one works. And the same as fresnoite structure, 0 0 + ½ ½ turns out to be the correct 
combination. 
For translation parts use combination 0 0 + ½ ½ 
Re-create refinement reflection file 
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8. Refinement of modulated structure – position modulation
Make a copy for modulated structure: “mod_P4bm” to work with
Make sure fix command “fixed origin O2” is present
“Edit atoms”: set two position modulation waves for all atoms
This means one harmonic wave along the first wave vector (q1) and one harmonic wave
along the second wave vector (q2)
Run refinement
Refinement converges with the following Robs values for all reflections, main reflections and
1st satellites: 6.9%, 5.73%, 12.75%
“Edit atoms”: add two modulation waves for ADP 2nd on all atoms
Run refinement
Refinement converges with slightly better Robs values: 6.82%, 5.7%, 12.4%. There are
warning for negative ADP for V atoms. This can be fixed by fixing the ADP to a reasonable
positive value, which won’t change the R values much.

9. Extinction correction
“Parameters → Extinction”

Select “Isotropic-Becker&Coppens” “Type 1” “Lorentzian” 
Change Radius [cm] to 0.1 and set the starting GIso to a smaller value, i.e. 0.0001; OK 

Double-click Refine and refine the structure 



Refinement converges with slightly better Robs values: 6.18%, 4.96%, 12.28%. 
Check the extinction coefficient through “Parameters → Extinction” 

Plot a 5x5x1 super structure. Each individual V polyhedron is not distorted, the framework is 
modulated by changing the angles between the polyhedra.  



10. Reimport data and create merged refinement reflection file

Make new copy for modulated structure: “mod_P4bm_merged” to work with 
“File → Reflection file → Import/modify the reflection file”: 



IMPORT NEW 
Select “reflection file corrected for LP and absorption”; NEXT 
Select “General file on I”, enter file name “K2V3O8_Niggli.hkl”, change Input format to 
(6i4,2f8.2); NEXT 



Select Neutrons and change Wave length to 0.4; NEXT Leave all settings unchanged; NEXT 

OK to continue with the old ones 

The program reads 26335 reflections; 
OK; FINISH 



Delete the original data by clicking DELETE

Highlight the newly imported data and OK; YES to accept the data set 
Follow default steps of the reflection wizard 
The program discards 242 reflections, 110 observed, Rint=10.23%. This newly imported data 
merged 21654/26093 reflections to 5488/6034 reflections, which would expedite the 
refinement process by a lot. 
“Parameters → Scale”: 



Change Maximal number of scales to “6” 

Change all the scales to “0” except scale1, and fix all except scale1 for refinement. 



Double-click Refine and refine the structure  
Refinement converges with Robs values: 6.30%, 3.72%, 13.40%. 

In most cases where the instrument is well-calibrated, the refinement result should be 
similar for the merged and unmerged data. However, the extinction correction is dependent 
on the wavelength which is different for peaks collected from different runs, and merging 
data from different runs would erase that information. Therefore, the unmerged data is 
recommended for publication especially for crystals with strong extinction. 

11. Refinement of modulated structure with subgroup symmetry
“Tools → Transformations → Go to subgroup structure”:



SELECT NON-ISOMORPHIC SUBGROUP; select Cmm2 
The discarded peaks are mostly violating the extinction condition of the b-glide plane, so P4 
and Cmm2. The average structure shows clear P4bm symmetry, with all the mirror planes 
present, and the most probable way to break the symmetry is the modulation happens along 
only one direction, instead of 2. (3+1)d structure for tetragonal structure is only possible 
when the modulation is along c-axis, which obviously isn’t the case in this structure. 
Therefore, the most probable symmetry is orthorhombic Cmm2. 



OK; NEXT; NEXT select the default operator; NEXT 
Name the structure “mod_Cmm2_merged”; leave the Make as twinned structure box 
checked 
The program will automatically create twin domains with equal volume and have the twin 
matrix applied. 
NEXT; FINISH 
Follow default steps of the reflection wizard 
Only 16/67 reflections are rejected as systematically extinct for the new space group, all of 
them are really weak peaks. 
Don’t apply the transformation at the end; NO 

You can transform to the standard setting anytime you want, keep the structure in the 
primitive setting would allow easy reimportation of the data if you want to refine the 
structure against the unmerged data 
YES to continue with the new structure 
Open Edit atoms, SELECT ALL to edit/define atoms 
There are 12 atoms now, all but O2 and V2 are duplicated to two sites from the tetragonal 
structure.  
Reduce the number of modulation waves to 1 for both position and ADP 2nd. 



OK; OK; YES to accept changes 
We came from superspace group P4bm(α,α,½)(-α,α,½)0gg to Cmm2(β,0,½)0s0(β,½,0)00s, 
which is still a (3+2) dimensional superspace group. This is necessary because the data 
imported is in the form of a (3+2) dimensional structure, even though it could be a (3+1)d 
structure with 90 degree twinning. By reducing the number of modulation waves to 1, we 
are only allowing the modulating along one direction to happen, which effectively makes the 
symmetry to be Cmm2(β,0,½)0s0, which is a (3+1)d group. This works pretty easily in this 
case because only first order satellite peaks are observed in the diffraction pattern. If higher 
order satellite peaks are observed, we would need to define the 3rd, 4th and higher order 
modulation waves, and add fix commands to fix all the even order modulation waves to be 
zero. 
Change the damping factor to 0.5 and start to refine the structure  
Refinement converges with Robs values: 6.54%, 4.39%, 13.13%, 12.99%. It may take a long 
time to reach the convergence criteria, you can end the refinement early when it gets close. 

“Parameters → Twin fractions”; REFINE ALL; OK; YES to accept changes 



Double-click Refine and refine the structure with twin fractions turned on 
Refinement converges with Robs values: 6.47%, 4.38%, 12.56%, 13.09%. The resulting twin 
fraction is 0.472126. 

Open EditM50 and the symmetry tab 
Because the structure is in non-standard setting for space group Cmm2, there is no entry in 
the space group box, only the symmetry operation listed. We can now reimport the hkl file 



as TOPAZ format to refine the structure against the unmerged reflection file, following 
Reimport data and create merged refinement reflection file steps, the program will 
automatically adjust the number of scale factors this time.  

12. Transform the structure to standard orthorhombic setting

“Tools → Transformations → Cell transformation”:

Click BY A MATRIX, enter the transformation matrix shown when we created the subgroup 
structure. 



 
OK; OK 



 
 
OK to rewrite the old structure. 
Follow default steps of the reflection wizard 
Open EditM50 and the symmetry tab 
The space group box correctly displays Cmm2 with origin shift ¼ ¼ 0 
“Tools → Transformations → Origin shift”: 

 
Enter 0.25 for x1 and x2 



 
OK 
“Tools → Transformations → Change modulation vector”: 

 
The modulation vectors have negative values now, it’s better to change them to positive 
values. 
q1’= (0 0 0) + (-1)*q1 + (0)*q2 
q2’= (0 0 1) + (0)*q1 + (1)*q2  
and click the upward arrow

 
Now the transformed modulation vectors are all positive values  
OK; OK to rewrite the old structure 
Follow default steps of the reflection wizard 



The structure is in standard setting of the space group symmetry now.  
Double-click Refine and refine the structure  
If you are refining against the unmerged data set imported in TOPAZ format, the refinement 
eventually converges with Robs values: 6.15%, 4.98%, 11.95%, 12.05%. 

 
Plot a 5x1x1 super structure. This structure only have modulation along a-axis and is periodic 
along b and c-axis. 

 
 
 

 
 
 

 
 




